- Fehlermeldung im Client-Log
com.levigo.jadice.server.JobException: Failure during server-side initialization on JADICE-SERVER-JS.REQUEST at com.levigo.jadice.server.client.jms.JMSJobController.performHandshake(JMSJobController.java:579) at com.levigo.jadice.server.client.jms.JMSJobController.submit(JMSJobController.java:365) at com.levigo.jadice.server.client.DefaultJobInternalImpl.submit(DefaultJobInternalImpl.java:74)
- Fehlermeldung im Server-Log
WARN [; core.ThreadPoolJobScheduler; JadiceServer job scheduler master thread]: Not executing job due to expired request message: (…)
- Typische Ursache
Die Uhrzeiten von Client und Server weichen stark voneinander ab.
- Lösung
Untersuchen Sie die Uhrzeiten von Client und Server und synchronisieren Sie diese gegebenenfalls.
- Fehlermeldung im Server-Log
javax.jms.JMSException: Failed to build body from bytes. Reason: java.io.IOException: <Node-Klassenname> at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35) at org.apache.activemq.command.ActiveMQObjectMessage.getObject(ActiveMQObjectMessage.java:183) at com.levigo.jadice.server.core.JMSServerJob.<init>(JMSServerJob.java:267) at com.levigo.jadice.server.core.ThreadPoolJobScheduler$SchedulerThread.handleMessage(ThreadPoolJobScheduler.java:203) at com.levigo.jadice.server.core.ThreadPoolJobScheduler$SchedulerThread. run(ThreadPoolJobScheduler.java:122) Caused by: java.io.IOException: (…)
- Ursache
Der vom Client erzeugte
Job
referenziert eineNode
-Klasse, die nicht im Klassenpfad des Servers vorhanden ist.- Lösung
Überprüfen Sie den Klassenpfad des Servers und fügen Sie die fehlende Bibliothek hinzu.
- mögliche Fehlermeldungen im Client-Log
javax.jms.JMSException: Failed to build body from bytes. Reason: java.io.IOException: com.levigo.jadice.server.shared.jms.ServerMessage$InitializationResponse javax.jms.JMSException: Failed to build body from bytes. Reason: java.io.InvalidClassException: com.levigo.util.internal.log.qualified.ResolvedQualifiedLogEvent; class invalid for deserialization
- mögliche Ursache
Es sind mehrere JMS-Provider im Klassenpfad des Clients vorhanden.
- Lösung
Verwenden Sie nach Möglichkeit in Ihrer Anwendung nur einen JMS-Provider. Falls dies nicht möglich ist, ändern Sie die Reihenfolge des Klassenpfads so, dass der JMS-Provider, der für jadice server verwendet wird, Vorrang hat.
- Fehlermeldungen im Server-Log
java.lang.StackOverflowError (…) at org.lobobrowser.html.parser.HtmlParser.parseToken(HtmlParser.java:642) at org.lobobrowser.html.parser.HtmlParser.parseToken(HtmlParser.java:679) at org.lobobrowser.html.parser.HtmlParser.parseToken(HtmlParser.java:679) (…) at org.lobobrowser.html.parser.HtmlParser.parse(HtmlParser.java:507) at org.lobobrowser.html.domimpl.HTMLDocumentImpl.load(HTMLDocumentImpl.java:386) at org.lobobrowser.html.domimpl.HTMLDocumentImpl.load(HTMLDocumentImpl.java:366) at org.lobobrowser.html.parser.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:98)(…)
- mögliche Ursache
Das Parsen von ungünstig strukturierten HTML-Dokumenten übersteigt die maximal zulässige Stack-Tiefe der JVM.
- Lösung
Erhöhen Sie die maximal zulässige Stack-Tiefe der JVM, z. B. durch Setzen des Parameters
-Xss2048k
in der Dateiwrapper/wrapper.conf
(falls eine Oracle / SUN JVM eingesetzt wird).